PDA

View Full Version : Q-Fan control



Harrison
9th February 2012, 14:01
I've just been building a new PC (will post some more in the Photobooth once complete) and have used an Arctic Cooling Freezer 7 Pro Rev. 2 for the CPU cooler, as I really like this device and use them in all my systems.

However the motherboard isn't correctly detected the fan and keeps complaining that no CPU fan is detected and to press F1 to enter setup.. then I can leave the BIOS and boot as normal. Then once in Win 7 Asus Probe II also throws up alerts about the fan being 0 RPM.

I know the fan is working correctly and spinning as I can see it, and it is keeping the i7 under 30 degrees.

Some people have said on the Asus forums to disable Q-Fan control in the bios. I've always had this enabled in all my other PCs and it has worked fine with the same CPU cooler. I did read that the second generation Sandy Bridge motherboards don't like Fans that idle at 600RPM or lower, and this one is idling around that speed.

I noticed in the BIOS you can set a lower fan speed limit for Q-Fan, so I set it down to 400RPM before alert, but it is still doing it.

Question is, if I disable Q-Fan will it force the fan to run at 100% all the time? This will obviously keep the CPU nice and cool, but I don't want it doing that. I want it controlled to speed up and slow down when needed. Or will the motherboard/OS still adjust the fan speed even with Q-Fan disabled?

Powerpie5000
9th February 2012, 14:12
I would double check that the fan is connected to the correct header as only the CPU fan header supports Q-fan (as was the case with my old AMD system)... I'm using the same cooler here with a Core i5 2500 and it's working great! Does your board have 3 or 4 pin fan headers? What model is the board? I'm pretty sure the fan can still be controlled with Q-fan disabled... Intel have there own fan control method similar to AMD's Cool ' n' Quiet technology... I'll see if i can find it in my bios.

EDIT: Ok my Intel Core i5 (sandy bridge) system has the options for Intel QST and Smart Fan control, see if your one has something similar as Q-fan is just an Asus thing.

Harrison
9th February 2012, 14:24
The motherboard is an Asus P8Z68-V Pro/Gen 3 running a Sandy Bridge i7 2600K.

The fan is plugged into the 4 pin CPU-Fan header so that is correct. This MoBo does however also have 2 additional CPU fan headers (4 pin and a 3 pin) with optional written next to them. I'm wondering if these are for coolers that have more than one fan, although I'm tempted to see what happens if I connect to to that 4 pin header instead.

Powerpie5000
9th February 2012, 14:46
The motherboard is an Asus P8Z68-V Pro/Gen 3 running a Sandy Bridge i7 2600K.

The fan is plugged into the 4 pin CPU-Fan header so that is correct. This MoBo does however also have 2 additional CPU fan headers (4 pin and a 3 pin) with optional written next to them. I'm wondering if these are for coolers that have more than one fan, although I'm tempted to see what happens if I connect to to that 4 pin header instead.

Seems many people are having fan issues with that board (not just with Arctic coolers)... Try plugging it into the header that says 'CPU_FAN_OPT' and see if it works. I wouldn't bother using the 3-pin connector as you'll most likely lose any kind of fan control.

---------- Post added at 14:46 ---------- Previous post was at 14:36 ----------


I did read that the second generation Sandy Bridge motherboards don't like Fans that idle at 600RPM or lower, and this one is idling around that speed.

I noticed in the BIOS you can set a lower fan speed limit for Q-Fan, so I set it down to 400RPM before alert, but it is still doing it.

The Arctic Freezer 7 Pro rev 2 operates at speeds of 900-2200 RPM (according to the specs)... Mine runs at just over 1000 RPM when the PC is idle and picks up pace when gaming, but not by too much (and it still stays cool and quiet).

Maybe try another cooler that states it can run as low as 600 rpm? Have you tried updating the bios? It could even be a sensor issue with the board.

Harrison
9th February 2012, 15:30
It's only idling right down at 600RPM when the CPU is idling and the speed drops to 1.6GHz. As soon as it jumps back to 3.4-3.8GHz if picks up speed to around 1000-1200RPM, so it looks like it is being controlled, just the sensors/software can't correctly measure it when it goes down towards 600RPM.

I've been reading loads of forums about this and you are right. Lots of people saying the same issue with different coolers. Might just disable Q-Fan then and monitor it for some time to see what happens. Tempted to also try the CPU_FAN_OPT header as loads of people have confirmed it is PWM controlled.

I'm running the latest BIOS revision, so it will be interesting to see if Asus release an update soon that fixes this issue.

Harrison
17th February 2012, 18:42
After adjusting the idle alert in the bios lower it hasn't set the CPU fan error alert off since. Ai suite still didn't like it so I've deactivated it.

I've now however deactivated qfan in the bios and the fan seems to be running at 2400 rpm, which I assume is the full speed without any control? So is it worth using a program to control speed? I've been monitoring cpu temps and haven't noticed any higher or lower temps either way when idling, or under load.

robinsonb5
17th February 2012, 18:47
So is it worth using a program to control speed?

Is the noise annoying you? If so, yes it is! Otherwise, probably not!

TheCorfiot
17th February 2012, 18:48
So is it worth using a program to control speed?

Is the noise annoying you? If so, yes it is! Otherwise, probably not!

Took the words straight out of my mouth :lol:

Harrison
17th February 2012, 20:06
Well.. My wife is now moaning the pc is making more vibrations through the floor in the living room, and it's now a kind if pulsing vibration which is annoying her. So I think I need to dampen that somehow or risk her murdering me. Lol.

Any ideas on a way to generally dampen a pc to stop it vibrating the floor?

robinsonb5
17th February 2012, 20:19
Any ideas on a way to generally dampen a pc to stop it vibrating the floor?

Just put something between the PC's feet and and the floor. Either something big - as in a piece of furniture - or something soft, such as a thin piece of upholstery foam. A decent quality jiffy bag under each foot ought to do it.

cosmicfrog
18th February 2012, 06:05
levitation is the key

on a similar note my amd borad now thinks the cpu fan isn`t spinning fast enough too, this an old 939 board so it probably has something do with the phase of the moon or me pond water needs changeing

Powerpie5000
19th February 2012, 18:26
Well.. My wife is now moaning the pc is making more vibrations through the floor in the living room, and it's now a kind if pulsing vibration which is annoying her. So I think I need to dampen that somehow or risk her murdering me. Lol.

Any ideas on a way to generally dampen a pc to stop it vibrating the floor?

The vibration can't be caused by the CPU cooler as the fan uses soft rubber mounts, maybe try using rubber mounts for the case fans and hdd? I think you can also get rubber spacers/washers for the PSU too :)

D.B
19th February 2012, 19:13
I expect that future Bios updates will address these issues you are seeing. I returned this very board for a Gigabyte Z68, only to still see MIRROR RAID issues for removing power from the Mobo. The Stripe will validate itself everytime you re-power the mobo for having pulled the mains off. Not ideal for a server application tbh. :thumbsdown: