PDA

View Full Version : Found Amiga Mouse.



Hell_Labs
27th March 2010, 21:30
The plonker that sold me my amiga on ebay never bothered to make sure the mouse works. Anyone have a spare for cheap? Doesn't have to be commodore or even clean; just so long as it works.

tokyoracer
27th March 2010, 22:29
I might be able to help, il have to check in the loft tomorrow for you.

subcon959
27th March 2010, 23:13
I should have a couple of spare commodore mice. I'll dig them out and see if they still work ok.

AndyLandy
28th March 2010, 07:03
The plonker that sold me my amiga on ebay never bothered to make sure the mouse works. Anyone have a spare for cheap? Doesn't have to be commodore or even clean; just so long as it works.

Let's hope it's just the mouse and not a dead CIA chip. :-)

parcival
28th March 2010, 10:42
If that's the case I'm offering 2 cia chips (dil version) in the hardware section

Hell_Labs
28th March 2010, 12:14
Let's hope it's just the mouse and not a dead CIA chip. :-)

The mouse goes left and right, and it can left and right click, but not up or down. That can't be the chip, can it?

AndyLandy
28th March 2010, 12:30
Let's hope it's just the mouse and not a dead CIA chip. :-)

The mouse goes left and right, and it can left and right click, but not up or down. That can't be the chip, can it?

That's most likely the mouse. Might be worth pulling it apart and checking the wheels are clean and free of gunk. You never know. :-)

Hell_Labs
28th March 2010, 15:07
already done that step, even moved the rollers with my fingers. She's dead, Jim.

tokyoracer
28th March 2010, 20:22
Are you still after one of these mice? :)

Hell_Labs
28th March 2010, 20:57
yeah, you got one? how much? EDIT: I'll be out of town for a week starting 7AM. If you can PM me a price and your paypal adress I'll get it sorted before I leave, else it'll be next week.

tokyoracer
28th March 2010, 22:37
It's ok Hell_Labs, give it a week so I can get more organized. :)

In-fact thats ideal as i'm pretty busy at the moment. :thumbsup:

Hell_Labs
28th March 2010, 23:12
sounds good:coffee:

Hell_Labs
10th April 2010, 15:09
tokyoracer, what's going on? You've got my money, but I don't have that mouse. Why are you ignoring the PMs I sent you?

J.T.Kirk
10th April 2010, 15:33
Hm... http://www.amigahellas.gr/uploads/smil4639e0cc2e3d8.gif

---------- Post added at 17:33 ---------- Previous post was at 17:30 ----------



Let's hope it's just the mouse and not a dead CIA chip. :-)

The mouse goes left and right, and it can left and right click, but not up or down. That can't be the chip, can it?

I saw that now, but I had exactly the same problem when I received my wireless CDTV mouse. Left, right, not up and down and the buttons were working. I just cleaned everything and even open the mouse in two parts and then it worked for me.

Hell_Labs
11th April 2010, 03:27
*proved innocent*

rkauer
11th April 2010, 04:51
@Hell_Labs: please, re-edit the image to hide Chris's email and name? I know you are in anger, but showing other's people sensible information is a no-no in many levels.

Hell_Labs
14th April 2010, 20:37
I got it today.:thumbsup:

Because there was no name on it, the postman thought it was my sister's (she moved out a few months ago) package (????) and decided to "hold on to it for a while" (!?!?!?!?!)

If I didn't ask him about it, the bugger probably wouldn't have delivered it. So yeah, royal fail.