PDA

View Full Version : Review: OS 3.9 ongoing



mjnurney
5th April 2014, 09:01
Soooo

After a week of testing , crashing , freezing and running stable for no obvious reason if have a few pointers and questions about OS3.9 and ultimately a mini review.

Features

AmigaOS 3.9 from Haage&Partner supplied on CDROM with Emergency Boot Floppy disk.

Workbench
(AsyncWB adds asynchronous copying and delete functionality to Workbench)

Multimedia programs
(MP3 player, AVI & QT player, new CD player)

Web browser AWEB 3.4 SE
(new version)
GENESIS
(full Internet and network access)

AmiDOCK
(new program start bar)

WarpOS 5.0
(new version)

IomegaTools
(for Zip and Jaz)
new powerful Shell
(with extensive prefs)

automatic datatype recognition
(powerful and very flexible)

integrated unpacker
(lha, lzx, dms, zip...)

fast search
(search for, and in, files)

new picture datatype
(PPC-optimized)

many new Tools
(ASLPrefs, new Info requester, new watch, font cache, new color wheel, etc.)

extensive HTML documentation
(in English and German)

but here are the features I have :-)

1) Amidock

it looks nice but after boing bag 2 (I think or 1) is installed it locks the system and now gurus.

2) boing bag 3 & 4

They seem to kill PPC acceleration or at the very least is buggy and cause problems.

3) CD-ROM support and or fastATA problems ... my cd-rom / dvd-rom is just a pain in the butt. I can view some files but not others , some discs but not others and it freezes the system. Works just fine in 3.1

4) PPC acceleration.

I could not (after 6 hours of effort) get PPC acceleration to work from a clean CD install of 3.9. library files out of date , warpup updates , boing bag updates and then ..... slow file access and choppy PPC acceleration. Now this is no doubt down to me as other people use OS3.9 with no trouble at all but this however escaped me by a country mile.

I gave up and used Steves HDF of 3.9 classic. it works....

but on the plus side.

I like it more than 3.1 for some reason that I cannot explain really :-) its a bigger 3.1 install with more features and integrated tools that Classic workbench adds for free but its not as bloated as the classic install but expect add a lot of tools / apps to it oh and boing bag updates too.

Over all I think I will stay with 3.9 now as its new to me and feels like a semi modern update to 3.1 , after all ive been using that since the 90s...

I will post pics of it running and being tested.


min specs :

For improved performance, we recommend:


68030 or higher processor
8 MB Fast RAM
Graphics accelerator and/or scandoubler
Modem

To take full advantage of OS 3.9 we also recommend you add the following:


68060 processor with PowerPC accelerator card
16-bit sound card
32 MB Fast RAM
I/O Accelerator


My system

A1200 3.1 roms
PPC accelerator 260mhz
68060 60mhz
128mb ram
20gig 2.5 IDE
fastATA3
IDE / SCSI DVD
Indivision AGA

and a big fan.

roy_bates
5th April 2014, 09:23
amidock works here mike after boing bag 1 and 2 install.

mjnurney
5th April 2014, 10:19
is that on a PPC system Roy?



amidock works here mike after boing bag 1 and 2 install.

NovaCoder
5th April 2014, 10:31
Nice little review Mike :)

AmiDock is a bit of a CPU hungry SOAB (well that's the rumor), I avoid it for that reason.

Yep I prefer 3.9 too and I also have a soft spot for a standard 3.1 install, 3.5 is best avoided.

I'm currently running a pretty standard 3.9 install with BB1 & BB2 and a few other patches, I like to keep things simple.

:D

mjnurney
5th April 2014, 10:41
thanks :-)

i dont really know much about 3.9 or the PPC side of it but im learning slowly...


Nice little review Mike :)

AmiDock is a bit of a CPU hungry SOAB (well that's the rumor), I avoid it for that reason.

Yep I prefer 3.9 too and I also have a soft spot for a standard 3.1 install, 3.5 is best avoided.

I'm currently running a pretty standard 3.9 install with BB1 & BB2 and a few other patches, I like to keep things simple.

:D

roy_bates
5th April 2014, 10:43
is that on a PPC system Roy?



amidock works here mike after boing bag 1 and 2 install.


no mate.

but im not sure what difference that would make on a 68k os.

mjnurney
5th April 2014, 11:47
no me niether bud , anyway ive removed it from the start up along with tinymeter.

it gurus on winuae too if i use my hdd on it.



is that on a PPC system Roy?



amidock works here mike after boing bag 1 and 2 install.


no mate.

but im not sure what difference that would make on a 68k os.

Bhindi_Bhaji
7th April 2014, 22:45
This is going to be a very handy thread for me, thanks!! I've just ordered 3.9 from Vesalia and plan to have a play when it arrives.

I have a desktop Commodore A1200 with 3.1 ROMS, a blizzard 060 (only clocked at 50Mhz mind you) plus 128MB RAM, external CD ROM with squirrel adapter, hopefully it's all compatible and will perform ok!!

I've got an 80GB 2.5 IDE drive sitting at work ready, I just hope it's ok for the install.

Currently I have classic WB on a 4GB CF card which was all pre setup when I brought it from ebay.

I've had the 1200 since 92, but my experience is pretty limited as I only used it for games at the time, this is going to be a bit of a learning curve for me!!

voyager_1701e
8th April 2014, 15:20
Mike I did discover what caused my Amidock to crash every boot also...but for the life of me the exact remedy/cause has escaped me!

It was 1 of 2 things.....the first possibility was it was the way you installed 3.9. In that I mean, I think if you installed it over 3.1 or on a blank system Amidock screws up. If you install it over a 3.0 installation it was OK. Thinking about it now I am sure that fixed the problem for me (I've installed 3.9 a few times in the last month). The other thought was there was a problem library version, but I really think the above is the "cause".

If you've got time, try a couple of variations on the install process. I am a bit sure (being vague and general about being sure bit :) ) that install over 3.0 is the answer.