View RSS Feed

TMW2N

A500/600/1200 PSU refurb

Rate this Entry
I've got a couple of slightly dodgy power supply units for my Amigas, and one which is pretty rock solid, but since my A1200 is about to get a shiny 060 upgrade, I thought I better make sure the supply was up to the job.

I looked at doiing a recap on them, but decided against that when I found a suitable replacement module for a reasonable price.

This afternoon I ripped the guts out of the PSU I got with my 1200 (amusingly it's labelled A300 on the bottom of the case) and replaced it with the module purchased from Element 14 / Faarnell

http://uk.farnell.com/xp-power/ecp40...-3o/dp/1765317

The old supply was rated for
3A on 5v
500mA on 12V
100mA on -12V

Replacement is rated for

5A on 5V
2A on 12V
500mA on -12V

I measured the outputs under load on my A600, 12V measured 12.04V 5V measured 5.01V and the -12V was -12.06V I'm happy with that. It's a pretty straightforward swap to do, I had the appropriate JST connectors kicking about, but you could desolder the connectors from the board and connect wires directly.

I've got another two of these units on order, to replace my unexpanded A600 and my upgraded A600HD power supply units.
Categories
Uncategorized

Comments

  1. Tw1sted1981's Avatar
    Really useful information, was it straight forward in getting the new unit wired up? I am assuming because you used the original power case you also used the original Amiga power connectors? I am just starting to look into options with my PSU and wondering if it is easy to change what is inside of the Amiga to a more standard cable connector or to do as you have and refurb the PSU.

    -Chris