View RSS Feed

RetroMatt

Return to the Amiga 1200 - My Journey - Part 6

Rate this Entry
Quote Originally Posted by RetroMatt View Post
Part #6 - Sticks of Joy !

It's been a few days since I last posted - largely due to being busy fixing things for this and another project I've got going on. As the title suggests and I'd hinted at previously as being my next post, this update is surrounding all things joystick. You may recall from a previous update I posted that in total I have ordered 3 joystick's for this project: 1 x Suzo "The Arcade", 2 x Zip Stik and had 2 supplied with the Amiga: 1 x Quick Shot Apache & 1 x Slip Stik, missing the fire button.

It's fair to mention not everything has gone to plan with my Joystick repairs - adding some delays, so there will be future updates on this topic but I have got to a position now where I've got a couple of fully functional joysticks I can use when my motherboard gets back and I can reassemble my Amiga.

So - let's get onto an update on each:

Suzo "The Arcade"

This was the Joystick I purchased directly from Amiga Scene in the Netherlands - I've been very excited for this to arrive. I never owned one of these before but whenever I played on one I was always impressed.

Imagine my delight when this box arrived:

Click image for larger version. 

Name:	IMG_20200523_110812.jpg 
Views:	13 
Size:	92.5 KB 
ID:	157331

Much as I would have loved to just rip straight into the box, I was very careful - I don't want to break whatever's inside - as it was the only thing I'd ordered from the Netherlands the post mark did give it away - yet until the box is open you never really know what's inside - like Schrödinger's cat.

It was the Suzo though and is a thing of beauty to behold. It fit perfectly in my hand and the fire button was snappy to press but unfortunately there was a problem. Now, I went into this knowing that it was a refurb so knew it had been repaired, but I wasn't expecting it to be this stiff. When I pressed in a direction it felt as if the plastic was rubbing. It felt responsive and tested perfectly fine on the Tester but that darned rubbing - just made it feel wrong. Not wanting to have to have to contact the seller to return it, I thought I could take a quick look and see what was going on. Likely it would be a simple fix and it turned out it was.

One quick disassembly later and it became clear - there was no lubricant around the stick or the internal plastic components where it moved and sure enough, it was rubbing on the plastic when I moved it the stick. The repairer hadn't thought to apply some grease to it and the result was plastic on plastic rubbing in places. Enter stage right > my large tube of Multi-Purpose grease and a few cotton buds. I took to liberally applying some lubricant to the affected areas - here's a picture for posterity:

Click image for larger version. 

Name:	IMG_20200524_010257.jpg 
Views:	12 
Size:	120.2 KB 
ID:	157332

End result? Once reassembled this Joystick now responds like a dream. No rubbing just smooth motion in all directions. Much as I love a Zip Stik, if this play-tests as well as I think it will, it might become my daily choice. I'm still a little wary of the reliability reports, but initial impression is very positive. I just need my Amiga back now...

Zip Stik's (Two of them!)

You may recall, I purchased two "questionable" Zip Stik's. One advertised as fully working but had been in a loft for some time, the other advertised as Faulty. See if you can figure out which is which. Here's a picture of the two:

Click image for larger version. 

Name:	IMG_20200524_111523.jpg 
Views:	14 
Size:	103.4 KB 
ID:	157333

Well, did you guess ? Yep - the one of the right is the working one. It arrived looking so much tidier as if care had been taken. So - let's give a report on that one first. Overall, this Joystick is in fabulous condition. Before I even looked to refurb it, it tested perfectly fine and was exceptionally positive to movement and button presses. Imagine my further delight when I opened it up and found that the fire button's have already been refurbed to newer Micro Switches already.

As I'm a firm believer of "if it's not broke, don't fix it" I'll not be doing anything else to this joystick. It works great and feels just like old times when I hold it in my hand. Once the Amiga is back I will be putting it fully through its paces with the Suzo. I have spare Microswitches so if needs be I can always swap out anything which doesn't feel just quite right.

Which takes us on to Zip Stik #2. Oh dear, oh dear. Where to start.

Well, firstly - it arrived definitely as advertised - faulty. Up did test ok on the tester but other than that, everything else was dead. Now, that in itself wasn't too big a surprise. I had planned on refurbing and replacing all of the microswitches on this one in anycase - but, alongside it not working it just didn't feel right. Not only was the weight off, but the directions and fire buttons didn't have that familiar microswitch click to them. Now I know different brands of microswitch give different experiences, but this just felt completely wrong.

Screwdriver out - time to disassemble. Imagine my surprise finding this:

Click image for larger version. 

Name:	IMG_20200524_114412.jpg 
Views:	14 
Size:	128.8 KB 
ID:	157334

Not a separate microswitch in sight. Some kind of weird board with everything integrated. It has embossed upon it "Power Play ISS 4". I can only imagine this was some kind of cheap repair board from back in the day ? If anyone has any further information they can share on this it would be appreciated. In anycase, not only is it faulty but it's completely different to what I was expecting. As it was advertised as faulty I wasn't intending to send it back, so I put my thinking cap on. If this was some kind of cheap repair from back in the day, logic would follow that I could return it back to a fully working microswitched Zip Stik ? I had most of the parts so why not give it a bash...

So first things first, I disassembled my working Zip Stik to check it out. This is where I noted a few differences.

1) The screw holes from the base to the top part were in slightly different places. Interestingly, I can actually screw the bases on either joystick, but they don't feel the same.
2) The base on the faulty joystick is missing the plastic parts which hold microswitches in place. This would need to be solved.
3) The joystick "sticks" themselves were different. The working one is black, the non working one is white.
4) The white one sits lower down in the base of the joystick than the black one. This would make fitting an autofire difficult.
5) On the white platform, two of the screw holes I need to use to secure microswitches into place are still blanked off. This indicated to me that that part was either new, or this joystick had never been a microswitch variant. Still, I wasn't going to be deterred.

Now, at the time of writing, this joystick is still a work in progress. I only have black and red wire in my toolkit and as I'm going to need to completely rewire this I'd prefer to do it with correctly colour coded wires so I've ordered some along with 4.8mm crimps. My plan is to get this Zip Stik as close as possible back to original working order and condition. That said, even without being wired up I have been able to test out the theory to some degree and have temporarily got all of the microswitches secured in place (I did some clever Stanley Knife work to uncover the needed 2 screw holes) and tacked down the fire switches too.

Here's what it looks like at the moment:

Click image for larger version. 

Name:	IMG_20200525_095102.jpg 
Views:	15 
Size:	104.3 KB 
ID:	157335

As you can see in the picture, because the white platform sits raised the place where the autofire switch board would go there is a microswitch in the way. This may mean adding auto fire is out of the picture - add to the fact I've not been able to source a replacement circuit board as yet. A custom board might work if I can figure out where to locate it, but it seems overkill at this point as I have a working Zip Stik with Auto Fire.

So, the good news is that in this configuration when assembled it now feels like a Zip Stick when pressing the directions and fire buttons. It returns nicely back to its start position and is responsive. I'm quietly confident I'll return this to a fully working microswitched Zip Stik once the wires arrive so I can wire this up properly.

I've also disassembled the ISS 4 board originally in it, to remove the cable & auto fire switch. Obviously I'll be using the cable and the auto fire switch will be going in my box of bits to look at again another day.

End result ? 1 fully working Zip Stik (#1) with Auto Fire, 1 Zip Stik(#2) still under refurbishment without Auto Fire - this will end up being effectively a complete interior reconstruction by the time I'm done.

Slip Stik

Not really much to update on this one at the moment. Parts for this were really difficult to source as I mentioned before - which meant I had to get some of them from the US. As of writing, they still haven't arrived yet so I've not done anything of note here yet. The faulty Zip Stik took more of my time than I was intending in any case - but this will be up for repair and upgrade to a microswitched fire button as soon as all of the pieces arrive.

Quickshot Apache

This was the joystick which came with the system. Good news - it fully works ! Bad news - just not the joystick for me. This feels very Flight Simulator-y to the touch. When I pull together my first For Sale post this will be included. For now, I'm going to keep a hold of it - just in case I need to rob it for parts.

..and there you have it...

I've now got 2 fully functional joystick's for my setup. They are:

1) Suzo "The Arcade" & 2) Zip Stik #1 (Auto Fire model)

Both in fantastic condition and full working order - two is all I need for some great two player action - and that is what I have.

Next order of business for these is to get them hooked up to the Amiga when it's back and put them through their paces. Let's see which one I ultimately prefer for my Daily Gamer.

Here's a picture of my two babies to leave you with..

Click image for larger version. 

Name:	IMG_20200525_101438.jpg 
Views:	15 
Size:	89.5 KB 
ID:	157336

Until next time!
Tags: None Add / Edit Tags
Categories
Uncategorized

Comments

  1. zChris's Avatar