Page 15 of 16 FirstFirst ... 5111213141516 LastLast
Results 141 to 150 of 157

Thread: New board: The VIC-IIČ - PAL/NTSC switch board for Commodore 64

  1. #141
    Retro YouTuber Starglider's Avatar
    Join Date
    Apr 2014
    Country
    US&A
    Region:
    CA
    Posts
    543
    Feedback
    4 (83%)

    Default

    Wes, your work looks exemplary. Thanks for sharing as it's easier for us than working blind.

    We're discussing and testing a few setups here and will be in touch within 24 hours.

    (Please also note Amibay seems to keep going down and I had some trouble sending this reply.)
    Starglider aka Perifractic

    "Recordar es vivir" | Remembering is living

  2. #142
    Retro YouTuber Starglider's Avatar
    Join Date
    Apr 2014
    Country
    US&A
    Region:
    CA
    Posts
    543
    Feedback
    4 (83%)

    Default

    Hi again, could you try this:

    Edit:
    Remove the minigrabbers.
    Reinstate them on the same pins but at the bottom.

    It seems some C64 revisions might have these pins reversed.

    Let us know how you get on. Thanks.
    Last edited by Starglider; 4th November 2019 at 03:07. Reason: Correction
    Starglider aka Perifractic

    "Recordar es vivir" | Remembering is living

  3. #143
    Wes256's Avatar
    Join Date
    May 2016
    Country
    USA
    Region:
    NorthEast USA
    Posts
    52
    Feedback
    2 (100%)

    Default

    OK, swapped the mini clamps but the relays are still oscillating, didn't we cover this with the troubleshooting step that 1stage provided a few posts ago?

    Quote Originally Posted by Starglider View Post
    Hi again, could you try this:

    Remove the minigrabbers.
    Reinstate them on the same pins but the other way around.

    It seems some C64 revisions might have these pins reversed.

    Let us know how you get on. Thanks.

  4. #144
    1stage's Avatar
    Join Date
    Sep 2018
    Country
    United States
    Region:
    Woodland Hills, CA
    Posts
    11
    Feedback
    0

    Default

    Ah. 250425 and 250466 boards (BLUE VIC-II card), clip the hooks to the BOTTOM middle and BOTTOM right pins of the C64 power switch.

    This has been corrected in the manual.

  5. #145
    Wes256's Avatar
    Join Date
    May 2016
    Country
    USA
    Region:
    NorthEast USA
    Posts
    52
    Feedback
    2 (100%)

    Default

    Yes, this was the issue, thanks.


    Quote Originally Posted by 1stage View Post
    Ah. 250425 and 250466 boards (BLUE VIC-II card), clip the hooks to the BOTTOM middle and BOTTOM right pins of the C64 power switch.

    This has been corrected in the manual.

  6. #146
    Retro YouTuber Starglider's Avatar
    Join Date
    Apr 2014
    Country
    US&A
    Region:
    CA
    Posts
    543
    Feedback
    4 (83%)

    Default

    Sorry for the misunderstanding but we're glad it's working now!
    Starglider aka Perifractic

    "Recordar es vivir" | Remembering is living

  7. #147
    bladepoint's Avatar
    Join Date
    Nov 2019
    Country
    Canada
    Region:
    ON
    Age
    29
    Posts
    5
    Feedback
    0

    Default

    I had the same issue with a 250425 board, and swapping the probes to the bottom fixed the oscillation issues for me as well. Now I'm getting a weird black and white checkerboard effect with my NTSC chip. I know the chip is good, since it's the native chip, and I get an otherwise stable picture both through the RF modulator and composite video. The PAL chip seems to work just fine, having gone through a few runs of the Wonderland XIII demo.


    Click image for larger version. 

Name:	checker.jpg 
Views:	7 
Size:	207.0 KB 
ID:	151151Click image for larger version. 

Name:	checker close.jpg 
Views:	6 
Size:	218.8 KB 
ID:	151152

  8. #148
    Retro YouTuber Starglider's Avatar
    Join Date
    Apr 2014
    Country
    US&A
    Region:
    CA
    Posts
    543
    Feedback
    4 (83%)

    Default

    Hi, have you tried the troubleshooting steps at the end of the guide?
    Last edited by Starglider; 5th November 2019 at 07:36. Reason: Correction
    Starglider aka Perifractic

    "Recordar es vivir" | Remembering is living

  9. #149
    bladepoint's Avatar
    Join Date
    Nov 2019
    Country
    Canada
    Region:
    ON
    Age
    29
    Posts
    5
    Feedback
    0

    Default

    I haven't tried the capacitor swap yet. The instructions read like that fix was specific to the 250407 boards, and I couldn't find anything marked "C70" near the video circuit. I do have a C15 that looks promising, but I don't want to get too enthusiastic with the iron without confirmation. Is that the right cap to swap?
    Click image for larger version. 

Name:	IMG_0018(Edited).jpg 
Views:	6 
Size:	216.3 KB 
ID:	151153

  10. #150
    Retro YouTuber Starglider's Avatar
    Join Date
    Apr 2014
    Country
    US&A
    Region:
    CA
    Posts
    543
    Feedback
    4 (83%)

    Default

    Ah, in that case I don't believe that would help (or at least we have no data about that yet.)

    Obviously we're dealing with very old machines and Commodore didn't make them all identical as we all know.

    Could you share close up photos of your work as it's easier for us to look for possible anomalies please?

    And needles to say, you get a colour image with your TV using that same NTSC chip without the VIC-IIČ PAL/NTSC Switcher, correct?
    Starglider aka Perifractic

    "Recordar es vivir" | Remembering is living

Page 15 of 16 FirstFirst ... 5111213141516 LastLast

Similar Threads

  1. Replies: 14
    Last Post: 21st May 2016, 02:24
  2. Wanted Fully Socketed NTSC C64c Short Board
    By ziggystar12 in forum Commodore
    Replies: 0
    Last Post: 20th April 2016, 18:14
  3. Wanted C64c NTSC mother board only
    By ChrisUnionNJ in forum Commodore
    Replies: 2
    Last Post: 24th September 2015, 17:03

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •