Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: 1541 - rough looking but working (50Hz / 220V / EU / UK version)

  1. #11
    BobbinThreadbare's Avatar
    Join Date
    Jan 2019
    Country
    United Kingdom
    Region:
    Berkshire
    Age
    43
    Posts
    68
    Feedback
    8 (100%)

    Default

    Click image for larger version. 

Name:	IMG_20190708_094315034.jpg 
Views:	3 
Size:	179.0 KB 
ID:	148167

    As discussed - label showing it's the UK model, apologies for any inconvenience, I had assumed C= would have simply used the same innards for both regions.

  2. #12
    TheMightyMadman's Avatar
    Join Date
    Apr 2018
    Country
    United Kingdom
    Region:
    Stockton-On-Tees
    Posts
    115
    Feedback
    13 (100%)

    Default

    Interest declared, PM sent.
    C64 'Silver Label' (WGB 1465) C64 'Breadbin' C64 'Aldi' C64G C64C SX-64 C128 C128D (CR) C16 (64KB RAM) Plus/4 VIC-20 (Early) VIC-20 (CR) VIC-1541 1541 1541C 1541-II 1551 1570 1571 1701 1084S-D2
    Amiga 500+ (4MB RAM, 4GB CF)

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Sold ZX Spectrum 48K (Issue 3B) - fully working but cosmetically rough
    By BobbinThreadbare in forum Sales Archive
    Replies: 8
    Last Post: 28th May 2019, 08:24
  2. Closed A3000T PSU (220V-50Hz)
    By LTAC in forum Found Archive
    Replies: 8
    Last Post: 27th October 2015, 12:16
  3. Closed Slipstream Data Recorder (working but rough)
    By SunDown79 in forum Sales Archive
    Replies: 4
    Last Post: 10th November 2014, 18:00
  4. Sold Commodore 64 Breadbin (rough but working)
    By SunDown79 in forum Sales Archive
    Replies: 9
    Last Post: 6th November 2013, 12:02
  5. Wanted 220V transformers for 1541 and 1526
    By JHawk in forum Commodore
    Replies: 5
    Last Post: 28th March 2013, 09:18

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •