Hi all,

I've got a TT030 that doesn't boot and invariably shows a white-grey screen with a handful of black lines on the left, even with no cpu present. I bought it for parts over two years ago and it had no TOS chips, I put TOS 3.06 DE (modifying the TOS jumpers accordingly and yes the chips are in the correct orientation ). I have put all the jumpers in the correct orientation as per the TT manual (e.g. HD floppy etc)

Whenc hooking up a diag cartridge (tested ok on an STE) to it the result is the same, and only the cartridge power led lights up, not the other green lights

Here's what I did so far with the same result:

cold boot
warm reset
leaving on for 30 mins then reset or turn off then back on in case some chips needed warming up
tested voltages: fine, even tried with an AT PSU, same result
reseated all ICs
remove FPU
removed all extension boards (TT and ST RAM)
replace video chip (when removing the video chip the screen is black so I assume the original one is fine)
replace GLUE chip
replace CPU


I haven't tried replacing the funnel chip, could it be that?

I don't have an oscilloscope or are not equipped to check TTL high/low logic.

The CPU does however seem to get warm.

Any ideas anyone?

Would anyone offer to diagnose/repair the motherboard (for a fee obviously)?

Thanks in any case!