Results 1 to 8 of 8

Thread: Help with repair of Blizzard PPC 68060 603e

  1. #1
    chelnov's Avatar
    Join Date
    Feb 2016
    Country
    italia
    Region:
    cuneo
    Age
    39
    Posts
    46
    Feedback
    1 (100%)
    Blog Entries
    1

    Default Help with repair of Blizzard PPC 68060 603e

    Hi!
    accidentally removed the card from my computer while it was turned on
    now the card gives a black screen on boot.


  2. #2
    Amiga - The Survivor miggymad's Avatar
    Join Date
    Aug 2019
    Country
    United Kingdom
    Region:
    Hitchin
    Posts
    315
    Feedback
    29 (100%)

    Default

    Have a chat with stachu100 and see if he can help
    Last edited by miggymad; 7th February 2020 at 16:12.
    Vampire V4 Standalone PC Engine Everdrive Commodore 64 SD2IEC

  3. #3
    Amibayer! timtheloon's Avatar
    Join Date
    Apr 2015
    Country
    United Kingdom, England
    Region:
    Hampshire
    Posts
    2,648
    Feedback
    155 (100%)

    Default

    What he said
    Got too many Amigas, Think I gotta problem


  4. #4
    Online Gangster Amibayer! fitzsteve's Avatar
    Join Date
    Aug 2009
    Country
    UK
    Region:
    Sevenoaks, Kent
    Age
    40
    Posts
    21,686
    Feedback
    1020 (100%)
    Blog Entries
    2

    Default

    You can try first to refresh the firmware, if this doesn't work then off for repairs...
    My YouTube Channel:
    https://www.youtube.com/user/fitzsteve

    CD32 + TF330, A500+ Vampire V2, A1200T Black Box + Mediator B1260 + Killer K1 PPC

  5. #5
    piacc64's Avatar
    Join Date
    Mar 2011
    Country
    Italy
    Region:
    Piacenza
    Posts
    1,887
    Feedback
    133 (100%)

    Default

    i can test it
    Last edited by piacc64; 7th February 2020 at 22:33.

  6. #6
    chelnov's Avatar
    Join Date
    Feb 2016
    Country
    italia
    Region:
    cuneo
    Age
    39
    Posts
    46
    Feedback
    1 (100%)
    Blog Entries
    1

    Default

    Quote Originally Posted by fitzsteve View Post
    You can try first to refresh the firmware, if this doesn't work then off for repairs...
    Tnx! the card is reborn
    Last edited by chelnov; 8th February 2020 at 00:53.

  7. #7
    Online Gangster Amibayer! fitzsteve's Avatar
    Join Date
    Aug 2009
    Country
    UK
    Region:
    Sevenoaks, Kent
    Age
    40
    Posts
    21,686
    Feedback
    1020 (100%)
    Blog Entries
    2

    Default

    That's amazing, glad to hear that! I have had this black screen of death before and the flash brought her back

    Now look after it!
    My YouTube Channel:
    https://www.youtube.com/user/fitzsteve

    CD32 + TF330, A500+ Vampire V2, A1200T Black Box + Mediator B1260 + Killer K1 PPC

  8. #8
    Amiga - The Survivor miggymad's Avatar
    Join Date
    Aug 2019
    Country
    United Kingdom
    Region:
    Hitchin
    Posts
    315
    Feedback
    29 (100%)

    Default

    Quote Originally Posted by chelnov View Post
    Tnx! the card is reborn
    YAY!
    Vampire V4 Standalone PC Engine Everdrive Commodore 64 SD2IEC

Similar Threads

  1. Closed Blizzard PPC 603e 330 MHZ / 68060 - 50 MHZ 256 MB
    By Syntrax in forum Sales Archive
    Replies: 8
    Last Post: 28th December 2019, 22:21
  2. Closed Blizzard PowerPC 603e @ 200 MHz - 68060 @ 50 MHz
    By fresh46664 in forum Sales Archive
    Replies: 8
    Last Post: 26th February 2017, 11:15
  3. Replies: 1
    Last Post: 10th March 2016, 22:50
  4. Help with repair of Blizzard PPC 603e
    By amigo-mexicano in forum AmiOracle
    Replies: 14
    Last Post: 23rd March 2014, 11:26
  5. Closed Blizzard PPC 603e+ 240Mhz with 68060 50Mhz
    By bbrockie in forum Found Archive
    Replies: 6
    Last Post: 29th November 2009, 21:58

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •