Results 1 to 5 of 5

Thread: Repair for Apollo 1240

  1. #1
    Amibayer! austinsom's Avatar
    Join Date
    Feb 2012
    Country
    United Kingdom
    Region:
    Dorset
    Posts
    978
    Feedback
    67 (100%)

    Default Repair for Apollo 1240

    Hi all,

    Just had an Apollo 1240 come in that had a severe battery leak. Battery is now gone, and the leak has been cleaned up, but I suspect it may have caused other issues.

    As well as that, a cap had been ripped off by the Mach 130/131 chip taking the pads with it. I did manage to get a smaller cap with the correct values attached, although it looks a bit pony.

    Following a clean with lemon juice, it was bathed in IPA and dried out. On putting in the miggy, nada. Just a black screen. Tried the usual, pulling out a little, swapping xtal, different RAM, no RAM etc. Still no dice.

    CPU warms up, as does the xtal, but generally it is a bit dead.

    So, is there anyone out there who has taken one in this state and made it live! UK repairer preferred, but happy to send to Europe too.

    Let me know if you can help. Thanking you in advance

    Some pics of the card below (full size, but I can tone down if needed!):



  2. #2
    piacc64's Avatar
    Join Date
    Mar 2011
    Country
    Italy
    Region:
    Piacenza
    Posts
    1,917
    Feedback
    135 (100%)

    Default

    wash in ultrasonic washer

  3. #3
    Amibayer! austinsom's Avatar
    Join Date
    Feb 2012
    Country
    United Kingdom
    Region:
    Dorset
    Posts
    978
    Feedback
    67 (100%)

    Default

    Card has been rinsed with IPA and blown out with air - best I can do as have only a washer big enough for watch parts. Really needs someone to take a look

  4. #4
    Amibayer! hese's Avatar
    Join Date
    Aug 2008
    Country
    Finland
    Region:
    Savo
    Posts
    1,491
    Feedback
    261 (100%)

    Default

    As long as the MACH chips still work, I can fix the card.

  5. #5
    Amibayer! austinsom's Avatar
    Join Date
    Feb 2012
    Country
    United Kingdom
    Region:
    Dorset
    Posts
    978
    Feedback
    67 (100%)

    Default

    I would hope they still work, but have no way to test them

    I'll send you a PM shortly so maybe we can discuss! Thank you.

Similar Threads

  1. Wanted Accelerator card Blizzard 1240 or Apollo 1240
    By bobymiller in forum Amiga
    Replies: 1
    Last Post: 7th February 2018, 09:02
  2. Wanted Apollo 1240 and Blizzard 1240 vs 1260
    By Turican in forum Amiga
    Replies: 0
    Last Post: 31st July 2016, 20:47
  3. Replies: 8
    Last Post: 8th December 2015, 19:12
  4. Sold Apollo 1240/40 for repair
    By Mohican in forum Sales Archive
    Replies: 6
    Last Post: 10th March 2014, 21:55
  5. Replies: 29
    Last Post: 22nd November 2012, 20:38

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •