Page 51 of 101 FirstFirst ... 4147484950515253545561 ... LastLast
Results 501 to 510 of 1009

Thread: Tapuino, the $20 C64 Tape Emulator

  1. #501
    c64new's Avatar
    Join Date
    Jan 2014
    Country
    Italy
    Region:
    center
    Age
    58
    Posts
    68
    Feedback
    2 (100%)

    Default

    Quote Originally Posted by ozayturay View Post
    Quote Originally Posted by sweetlilmre View Post
    @ozayturay those look awesome! Unfortunately I can't add them with the Commodore logo as that is copyright.

    Ahhh, I didn't think of that. I removed the logo and made a few corrections to pin orders (like SD pinout to match popular MicroSD modules) and tagged it as TapuinoMini Type A - Version 1.01


    I have also made a new version which integrates my above schematic for read and write leds to the design (as pin headers) and tagged it as TapuinoMini Type A - Version 1.02


    Here are the pictures and desing files of both TapuinoMini versions:

    Attachment 85974 Attachment 85975 Attachment 85976

    Design Files For GitHub: https://dl.dropboxusercontent.com/u/...ini-GitHub.zip


    I will also made a TapuinoMini Type B PCB (both 1.01 and 1.02 versions) for using a cheaper Arduino ProMini clone of which A4 and A5 pins are on a different location. What I call Type A and Type B Arduino Pro Minis are linked below:


    Type A: http://www.ebay.com/itm/New-Pro-Mini...-/200957063666
    Type B: http://www.ebay.com/itm/New-design-P...-/400762710802

    Also here are links for a 1602 LCD with I2C builtin and a MicroSD module:

    http://www.ebay.com/itm/iic-i2c-twi-...e/310565065847
    http://www.ebay.com/itm/new-micro-sd...o/201128314754

    And a shopping list from may favourite seller alice1101983:

    http://www.ebay.com/cln/ozay.turay/T...t/104084938018
    You can create a new link with these PCB on http://dirtypcbs.com ?
    Thank you
    Last edited by c64new; 6th April 2015 at 17:20.
    [COLOR=#0000cd]:Commodore:[/COLOR][COLOR=#000080] |Vic20|C64|C64C|C64G|C64Aldi|SX64|C64DTV|C128|C128D|C128DCR|[/COLOR][COLOR=#000080]C16|Plus4[/COLOR][COLOR=#000080]|[/COLOR]
    [COLOR=#0000cd]:rainbow:[/COLOR][COLOR=#000080] |Amiga500|Amiga500+|Amiga600|Amiga1200|AmigaCDTV|Amiga1000|Amiga2000|[/COLOR][COLOR=#4b0082]
    :jester:[/COLOR][COLOR=#000080]|Z80NE Nuova Elettronica|Spectrum +2|MSX2 Philips NMS8280 Digitize & Superimpose|[/COLOR]

  2. #502
    sweetlilmre's Avatar
    Join Date
    Jan 2013
    Country
    South Africa
    Region:
    KwaZulu / Natal
    Posts
    750
    Feedback
    34 (100%)

    Default

    @sven1973 brilliant!
    @ozayturay / @c64new who's going to send me a board?
    Build a Tapuino!
    http://www.amibay.com/showthread.php?63166-Tapuino-the-20-C64-Tape-Emulator
    http://www.sweetlilmre.com

  3. #503
    braincell1973's Avatar
    Join Date
    Apr 2015
    Country
    england
    Region:
    norfolk
    Posts
    58
    Feedback
    6 (100%)

    Default

    Hi All,
    I built up a tapuino using a bare 328p chip which i programmed on a breadboard through ICSP.

    I can load taps fine but i have a strange problem.

    When i select a tap file it starts running immediately , that is it doesnt wait for the C64 to turn on the motor signal.That is on the LCD it display a capital "M" and the counter clocks up despite being on the C64 basic screen.

    Heres the kicker though , If i put the c64 in the "PRESS PLAY ON TAPE" state 1st , THEN start the tapuino playing it finds the tap file and pauses the load at the header (motor off) correctly and then starts the motor signal and loads the rest of the tap successfully.

    My question is this, Is the tapuino designed to be able to start playing back a tap without having a motor on signal ? or should it wait ???

    Im using a 4n25 wired as per the verobaord except going top a bare 328.

    Any help much appreciated....

    Also , Are those small pcbs for the minis going to be available ??

  4. #504
    ozayturay's Avatar
    Join Date
    Jan 2014
    Country
    Türkiye
    Region:
    Çanakkale
    Posts
    39
    Feedback
    0

    Default

    Check your motor and sense signals twice.

  5. #505
    braincell1973's Avatar
    Join Date
    Apr 2015
    Country
    england
    Region:
    norfolk
    Posts
    58
    Feedback
    6 (100%)

    Default

    Quote Originally Posted by ozayturay View Post
    Check your motor and sense signals twice.
    Deffo 6v on motor signal, SENSE seems to be ok too, Odd thing is the SENSE/MOTOR works fine when it finds the header.

    My problem only seems to be when sitting at the basic screen ;/

  6. #506
    ozayturay's Avatar
    Join Date
    Jan 2014
    Country
    Türkiye
    Region:
    Çanakkale
    Posts
    39
    Feedback
    0

    Default

    Quote Originally Posted by c64new View Post
    You can create a new link with these PCB on http://dirtypcbs.com ?
    Thank you
    It was on my previous post on page 50: http://dirtypcbs.com/view.php?share=...bd4e87a2a446f7
    But don't forget, they are not tested yet.

    Quote Originally Posted by sweetlilmre View Post
    @ozayturay / @c64new who's going to send me a board?
    Of course I can send you when they arrive.
    Last edited by ozayturay; 6th April 2015 at 18:52.

  7. #507
    c64new's Avatar
    Join Date
    Jan 2014
    Country
    Italy
    Region:
    center
    Age
    58
    Posts
    68
    Feedback
    2 (100%)

    Default

    Quote Originally Posted by ozayturay View Post
    Quote Originally Posted by c64new View Post
    You can create a new link with these PCB on http://dirtypcbs.com ?
    Thank you
    It was on my previous post on page 50: http://dirtypcbs.com/view.php?share=...bd4e87a2a446f7
    But don't forget, they are not tested yet.
    Ah true! Is already version 1.02. i did not see ...
    Quote Originally Posted by sweetlilmre View Post
    @ozayturay / @c64new who's going to send me a board?
    Of course I have to send it ... you're the protagonist of the project!
    Last edited by c64new; 6th April 2015 at 20:53.
    [COLOR=#0000cd]:Commodore:[/COLOR][COLOR=#000080] |Vic20|C64|C64C|C64G|C64Aldi|SX64|C64DTV|C128|C128D|C128DCR|[/COLOR][COLOR=#000080]C16|Plus4[/COLOR][COLOR=#000080]|[/COLOR]
    [COLOR=#0000cd]:rainbow:[/COLOR][COLOR=#000080] |Amiga500|Amiga500+|Amiga600|Amiga1200|AmigaCDTV|Amiga1000|Amiga2000|[/COLOR][COLOR=#4b0082]
    :jester:[/COLOR][COLOR=#000080]|Z80NE Nuova Elettronica|Spectrum +2|MSX2 Philips NMS8280 Digitize & Superimpose|[/COLOR]

  8. #508
    sweetlilmre's Avatar
    Join Date
    Jan 2013
    Country
    South Africa
    Region:
    KwaZulu / Natal
    Posts
    750
    Feedback
    34 (100%)

    Default

    Quote Originally Posted by braincell1973 View Post
    Quote Originally Posted by ozayturay View Post
    Check your motor and sense signals twice.
    Deffo 6v on motor signal, SENSE seems to be ok too, Odd thing is the SENSE/MOTOR works fine when it finds the header.

    My problem only seems to be when sitting at the basic screen ;/
    So to check:

    • MOTOR is going to the OPTO via R1 (430 / 300 Ohm)?
    • You flashed this via the IDE using an ICSP programmer?
    • Output of the MOTOR line should be LOW on power on, conversely the output of the 4N25 should be HIGH
    • What does the SENSE line read on power on (should be HIGH IIRC)?



    The firmware is going to set SENSE to LOW as soon as you start playing the tap. This should get the C64 to put the MOTOR line HIGH, dropping the 4N25 LOW (display goes to M indicating MOTOR on).
    (C64 turns the MOTOR on/off based on SENSE)

    Quote Originally Posted by braincell1973
    When i select a tap file it starts running immediately , that is it doesnt wait for the C64 to turn on the motor signal.That is on the LCD it display a capital "M" and the counter clocks up despite being on the C64 basic screen.
    This isn't how it works If the display is 'M' then the Tapuino thinks the MOTOR is ON, i.e. MOTOR line is HIGH and 4N25 is LOW.

    HTH
    -(e)

  9. #509
    sweetlilmre's Avatar
    Join Date
    Jan 2013
    Country
    South Africa
    Region:
    KwaZulu / Natal
    Posts
    750
    Feedback
    34 (100%)

    Default

    Also: I just wanted to say that it's amazingly humbling to see all of the incredible designs and implementations that you all come up with. I'm blown away by the inventiveness and awesome attitudes of everyone that I've met through this project.

    Thank you!
    Build a Tapuino!
    http://www.amibay.com/showthread.php?63166-Tapuino-the-20-C64-Tape-Emulator
    http://www.sweetlilmre.com

  10. #510
    stephenfalken's Avatar
    Join Date
    Jan 2014
    Country
    UK
    Region:
    Lancashire
    Posts
    433
    Feedback
    11 (100%)

    Default

    When the C64 is first turned on, even before you type LOAD the Tapuino will begin loading a TAP if you select one.

    This is the same behaviour as with a Datasette, pressing play on a tape will still start the motor going before you give it the load command.

    Correct usage should be to type LOAD or use Shift>Runstop, THEN select the tap file.

    Regards


Page 51 of 101 FirstFirst ... 4147484950515253545561 ... LastLast

Similar Threads

  1. Wanted Cbm 64 tape deck
    By owen2471 in forum Commodore
    Replies: 5
    Last Post: 21st September 2013, 18:43
  2. Sold TAKEN: C 116 with tape
    By antonikaroly in forum Sales Archive
    Replies: 4
    Last Post: 23rd August 2013, 19:19
  3. Sold C64 Tape Bundle
    By morcar in forum Commodore
    Replies: 6
    Last Post: 11th July 2013, 00:44
  4. For Sale Tape Drive
    By alpehut in forum Other
    Replies: 0
    Last Post: 21st April 2013, 12:17
  5. Closed Zx 16 microdrives tape with box
    By Virge in forum Sales Archive
    Replies: 1
    Last Post: 11th July 2011, 20:07

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •