Announcement

Collapse
No announcement yet.

A500 (r6a) 1MB CHIP RAM Modification: Caution dialup users: excessive H/W pr0n!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by rkauer View Post
    Another solution is making a redundant hack: solder in the chip RAM chips (valid only for revision #6 and #8.x boards) and then add a little circuit to have 1Mb chip and 512kb ranger. So the A500 will have 1Mb & 512kb Ranger. 1.5Mb RAM expandable to 9.5Mb (10.5Mb using a Megachip or other 2Mb Agnus board)!

    The circuit is very small but requires a couple of hard to find TTL ALS chips.

    Here is the hack (not my work, the diagram belongs to Pekka Pessi, revised by Hemiyoda):
    Unfortunately, it does not work on REV6A. Amiga turns on but the game starts, the program hangs.
    Workbench shows 1MB chip and 0.5 SLOW.

    Comment


    • Sorry for resurrecting an old post, but I attempted this mod:

      It seems to have worked, but: My A500 is showing 1MB chip RAM and 8MB fast RAM via HC533 accelerator w/8MB, 512 on Rev 6a Motherboard, and 512k on trapdoor A512 board.

      JP2 has proper continuity (top/middle pads)

      I cut JP7A trace bottom to middle. The bottom solder pad actually separated from the board . I'm still getting continuity with a multimeter between all three pads. Shouldn't there be no connection between these pads?

      Workbench 3.1 boots off the CF card on the HC533, Sysinfo shows the Fast/chip RAM OK, but now a ton of games begin to load and go through the intro or initial load screens but then hang. A few have worked, but a lot don't. Is this because of the extra 512k Chip RAM or is there a memory error of some type caused by my mod (that I probably screwed up)?

      Any help would be much appreciated. I've searched a lot but couldn't find anything about the continuity between the three pads on JP7A other than the trace between middle and bottom pad must be cut.

      Edited to add: I had done a KS ROM update (from 1.3 to 3.1) at the same time as the Chip Memory "hack". Installing a KS switcher and rolling back to 1.3 when playing the problem games has resolved the issue/s and it was not caused by the 1mb Chip Memory modification.
      Last edited by officer960; 25 October 2018, 12:47. Reason: Resolved Issue

      Comment


      • Hi,the caps are not needed for new RAM installed?
        Amiga 1200 REV 1D.4 ACA 1232 68EC030@25MHz 128MB CF 4GB ROM 3.1 ClassicWB Full
        Amiga 600 REV 2B A604 1MB CF 4GB ROM 37.350 WB 2.1

        Comment


        • did the JP2 cut but bought a new 512mb ram module for the trap door which had a soldered jumper to enable the extra ram without other mods needed its the boobip one seems to work mind you wish I had read Zetro's post first tried to unsolder the link and made a right mess of it but after cleaning and cleaning now it seems to work OK.
          ZX Spectrum Plus;Gaming Ryzen 7 PC; A4000 Cyberstorm MK2 128MB, MNT ZZ9000, Fast ATA.PS4,Pie3 in C64 case, MISTer, Ryzen 5 3500 PC. A500 RGB-HDMI v2 TF536. a600 Vampire V2 ecs v2 604n. I really really don't need more, or maybe I do!!!!

          Comment

          Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
          Working...
          X