Announcement

Collapse
No announcement yet.

A500 (r6a) 1MB CHIP RAM Modification: Caution dialup users: excessive H/W pr0n!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • cugar124
    replied
    did the JP2 cut but bought a new 512mb ram module for the trap door which had a soldered jumper to enable the extra ram without other mods needed its the boobip one seems to work mind you wish I had read Zetro's post first tried to unsolder the link and made a right mess of it but after cleaning and cleaning now it seems to work OK.

    Leave a comment:


  • kaini
    replied
    Hi,the caps are not needed for new RAM installed?

    Leave a comment:


  • officer960
    replied
    Sorry for resurrecting an old post, but I attempted this mod:

    It seems to have worked, but: My A500 is showing 1MB chip RAM and 8MB fast RAM via HC533 accelerator w/8MB, 512 on Rev 6a Motherboard, and 512k on trapdoor A512 board.

    JP2 has proper continuity (top/middle pads)

    I cut JP7A trace bottom to middle. The bottom solder pad actually separated from the board . I'm still getting continuity with a multimeter between all three pads. Shouldn't there be no connection between these pads?

    Workbench 3.1 boots off the CF card on the HC533, Sysinfo shows the Fast/chip RAM OK, but now a ton of games begin to load and go through the intro or initial load screens but then hang. A few have worked, but a lot don't. Is this because of the extra 512k Chip RAM or is there a memory error of some type caused by my mod (that I probably screwed up)?

    Any help would be much appreciated. I've searched a lot but couldn't find anything about the continuity between the three pads on JP7A other than the trace between middle and bottom pad must be cut.

    Edited to add: I had done a KS ROM update (from 1.3 to 3.1) at the same time as the Chip Memory "hack". Installing a KS switcher and rolling back to 1.3 when playing the problem games has resolved the issue/s and it was not caused by the 1mb Chip Memory modification.
    Last edited by officer960; 25 October 2018, 12:47. Reason: Resolved Issue

    Leave a comment:


  • TREXoldcomputer
    replied
    Originally posted by rkauer View Post
    Another solution is making a redundant hack: solder in the chip RAM chips (valid only for revision #6 and #8.x boards) and then add a little circuit to have 1Mb chip and 512kb ranger. So the A500 will have 1Mb & 512kb Ranger. 1.5Mb RAM expandable to 9.5Mb (10.5Mb using a Megachip or other 2Mb Agnus board)!

    The circuit is very small but requires a couple of hard to find TTL ALS chips.

    Here is the hack (not my work, the diagram belongs to Pekka Pessi, revised by Hemiyoda):
    Unfortunately, it does not work on REV6A. Amiga turns on but the game starts, the program hangs.
    Workbench shows 1MB chip and 0.5 SLOW.

    Leave a comment:


  • Olav_nordmann
    replied
    Okay, did some testing and my assumption seems to be correct. if your trapdoor RAM board does have an Enable/Disable switch, then you can just set it to "Disable" and JP7A won't matter for the 1M Chip mod. This way, ONLY JP2 needs to be changed.

    Leave a comment:


  • Olav_nordmann
    replied
    I understand this might be an old thread, and there is indeed lots of info on this topic, but there is one thing that never is mentioned anywhere.

    Some trapdoor expansions have an enable/disable switch. This switch simply puts either +5V or GND on the /EXRAM pin, and the trapdoor Slow-RAM will be disabled/enabled accordingly.

    With a switch like this, is it really nessecary to do anything with JP7A at all for the 1MB Chip mod? I mean, if leaving /EXRAM floating pulls it high, then just flipping the switch on the trapdoor expansion would be sufficient, and the only thing you would need to do is to cut and solder a switch to JP2.

    Leave a comment:


  • BLTCON0
    replied

    Leave a comment:


  • jcarvalho
    replied
    Hi! Just tried grounding pin 32 from Gary... The A500 don't boot Need some help here! To use the fully populated RAM sockets on my 500
    Many thanks,
    Jorge

    EDIT: Was my fault, soldered on the wrong 32 pin!!! Now is working!!!!!!! Thanks for all!!!!!
    Last edited by jcarvalho; 17 April 2014, 11:54.

    Leave a comment:


  • BLTCON0
    replied
    You didn't mention that you installed the extra 512 KB on the motherboard's empty memory chip sockets
    JP7A, when bridged, simply routes Gary pin 32 (EXTICK signal) to a trapdoor pin. When a trapdoor RAM expansion is connected, it grounds this pin, and Gary understands that a trapdoor memory expansion (slow/ranger RAM) is present at $C00000.
    So, obviously, when you use the motherboard's extra sockets, there's no trapdoor card to do the grounding for you and thus you must take care of grounding Gary pin 32 yourself.
    The rule is simple:
    For 512 + 512 : Gary pin 32 grounded
    For 1 MB chip: Gary pin 32 floating (unconnected)
    Last edited by BLTCON0; 14 April 2014, 15:47.

    Leave a comment:


  • jcarvalho
    replied
    1MB chip switching to 512+512

    Hi guys! Having some problems here.
    Bought a new switch for connecting the JP2 and JP7A, soldered the wires and continuity tests done. The problem is that when I switch to 512 KB I was expeting to see the other 512KB soldered as other ram or something like that, but when typing avail on a cli window, it only shows the original 512 chip ram and nothing else... Is this right? lets say, with the original connections applyied on motherboard via switch I can only see 512kb.... Need some help here, dont know what I have done wrong... When switching to 1MB chip every thing shows like it should... 1mb chip ram and nothing in fast (using the avail command on cli window)... My 500 has 1.3 workbench and original kickstart

    Many thanks for any kind help!
    Jorge
    Come on guys! a little help needed here!!!!! Just wanna see 512+512kb for games that dont like 1MB chip ram... The chips are in place!!! why cant I see the extra memory in non 1MB chip RAM??????????
    Last edited by jcarvalho; 12 April 2014, 13:36.

    Leave a comment:


  • roy_bates
    replied
    Originally posted by Bastich View Post
    Great tutorial
    This looks far easier than I thought it would be
    To make the 3 modifications switchable would this be appropriate?
    (I know this is a 4 way switch but I could not find a 3 way version)

    http://www.maplin.co.uk/p/toggle-switch-4pdt-fh08j

    Also I have a dead A500+ board I was going to salvage the memory chips from. Would these be fine to fit to a 6a board directly as I do not have a trapdoor expansion other than a dead A501.

    as long as the memory is ok it will be fine.its the same memory just more of it.

    Leave a comment:


  • Bastich
    replied
    Great tutorial
    This looks far easier than I thought it would be
    To make the 3 modifications switchable would this be appropriate?
    (I know this is a 4 way switch but I could not find a 3 way version)

    http://www.maplin.co.uk/p/toggle-switch-4pdt-fh08j

    Also I have a dead A500+ board I was going to salvage the memory chips from. Would these be fine to fit to a 6a board directly as I do not have a trapdoor expansion other than a dead A501.

    Leave a comment:


  • jcarvalho
    replied
    Nice! Will have to buy another suitable switch
    Thanks!!
    Last edited by jcarvalho; 5 April 2014, 01:34.

    Leave a comment:


  • BLTCON0
    replied
    Yes, JP7A must also be reconnected like it was before the mod.
    This is more or less to inform Gary that trapdoor RAM does exist in the $C00000 location, so that when the CPU tries to read/write stuff there it can actually be granted the (shared with the custom chips) bus to do so.
    I guess you can use two switches. Or some dual switch to simultaneously alter both JP2 and JP7A accordingly.

    Leave a comment:


  • jcarvalho
    replied
    Hi guys! I have decided put a switch on this mod. I only have soldered 3 wires to the pads of JP2 and soldered to a 3 pin switch. The problem is that in a position I can see the 1MB chip, but in the other position I only have 512kb chip and cant find the other 512kb in fast or other... What I am missing? Need to do something on JP7?
    My 500 is a rev 6A

    Thanks in advance!
    Jorge

    Leave a comment:

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Working...
X