Page 13 of 13 FirstFirst ... 3910111213
Results 121 to 123 of 123

Thread: 1084S-P LOPT+HOT replace

  1. #121
    Inactive Member emuboy's Avatar
    Join Date
    Nov 2017
    Country
    United Kingdom
    Region:
    Surrey
    Age
    36
    Posts
    1
    Feedback
    0

    Default

    Hello everyone,

    Sorry to necro this thread but looks like a lot of knowledgeable people here.

    I have a 1084S-P, I did bring back it home, it worked for maybe 4 hours and then it died.

    it's started to make an horrible noise and no image on the screen, me, as silly as I am, I went on and recapped it.

    No joy.

    Let me tell you what I found at the moment:

    - The transformer makes a squeaky noise that stops suddenly (instead of dying slowly) and it's possibly going in overcurrent protection. If I disconnect the PSU board from the rest and I power it, it only generate the "normal" CRT noise.

    - The capacitor I replaced are in the right direction and there are not shorts I can see.

    - If I touch the glass and I touch a grounded piece of metal I get static discharge (the flyback is ok?)

    - I don't remember (but could have been me) being able to have any sound out of the audio section.

    The HOT didn's seemed to be shorted but I tried it out while was on the pcb.


    Any idea? shall I just go for a flyback?

  2. #122
    Inactive Member e5frog's Avatar
    Join Date
    Nov 2010
    Country
    Sweden
    Region:
    n a
    Age
    46
    Posts
    64
    Feedback
    0

    Default

    I have an odd one.

    Philips CM8833 - so the same internals as a 1084S-P/P1, right?

    Got nothing but a squeal from the powerboard when powering up, recapped the powerboard and also changed the chopper transistor (on the heat sink).
    Also changed flyback and H.O.T. for the BU508AF which are supposed to be interchangeable.
    Voltages from powerboard seems fine (they did before as well), it has a quiet pitched sound when powered without powering the main board.

    Now I have some more life, like glow in the tube but it starts screeching after about a second past ON. Sounds like if you play a violin really slow or drag something over sand, possibly white noise-ish. I read the audio frequency of the sound to 15kHz. Can't really locate the source...

    Image on the tube goes bright white with several diagonal lines over the screen. Adjusting the SCREEN adjustment on the flyback doesn't make any difference, neither brightness or contrast knobs.
    After a few more seconds the image collapses to a small warped flashing rectangle - and that's where I shut the power off.
    Left is colorful spots that takes a really long time to disappear, mainly in the center of the screen.

    I have been meaning to do a complete cap swap but it would be nice to know if there are other parts to check before starting such a massive enterprise (I hate recapping these things).

    Any ideas, is my flyback broken perhaps (HR7506 replacing the AT2079-30101)?

  3. #123
    fbone's Avatar
    Join Date
    Aug 2020
    Country
    Greece
    Region:
    Attica
    Age
    43
    Posts
    2
    Feedback
    0

    Default

    Hi guys!

    I am new in town and could use your help! I saw @centaur2 messages long time ago about aligning the image on a 1084s-p.. I also have one in my hands that needs some maintenance. Im thinking to preventively replace HOT (D1577) and also recap.. but from what I read centaur2 broke the glue at two of the three "G shaped legs" to fix the slight misalignment - there are also two screws at the tube neck that maybe need some adjusting.. could you please provide some more info??

    thank you in advance!
    Last edited by fbone; 15th December 2020 at 10:31.

Page 13 of 13 FirstFirst ... 3910111213

Similar Threads

  1. Degaussing a 1084s
    By Hell_Labs in forum AmiOracle
    Replies: 8
    Last Post: 3rd December 2010, 12:35
  2. Replace CS PPC, CV PPC, Voodoo coolers
    By easy_john in forum Photo Booth
    Replies: 7
    Last Post: 3rd December 2010, 08:43

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •