A3000 Restoration Project

sunos4

Member
Joined
Apr 20, 2013
Posts
86
Country
UK
Region
Scotland
I do enjoy reading on here and elsewhere folks' stories of Amiga's rescued from battery damage, particularly A3000's. I have been after an A3000 to restore to fully working order for some time. This one came extremely dusty, but the battery had been removed. I haven't powered it on yet, the previous owner said he just got a black screen, so I thought I would remove the battery residue and clean away the dust for a closer look before I put it together and switched it on.

So far, I have cleaned the battery area with dilute vinegar and removed the Denise and Paula chips to check the sockets. I rinsed away the vinegar and will leave overnight to dry. I will need to obtain some Isopropyl alcohol and some cotton buds to give it a better clean tomorrow. I have noticed ROM 0 and 1 have been plugged into the wrong sockets, which may be the cause of the fault.

Does anyone know whether the Zip Fast Ram is 256K x 8 or 1M x 8? The part code is HM514402AZ8. All I can find is that they might be 2M but that cannot be right, can it? I have an IC chip puller somewhere and I want to find it to remove the PLCC chips and clean out their sockets before I power on.

A3000 001s.jpg A3000 005a.jpg IMG_0124a.jpg IMG_0123a.jpg
 

sunos4

Member
Joined
Apr 20, 2013
Posts
86
Country
UK
Region
Scotland
Sadly, this one has more serious underlying issues than I first though. I need to try to find someone to repair this, it is probably too valuable to try to attempt to fix myself.

I could try swapping in a spare ECS Denise chip I have somewhere, although the Denise socket looks pretty badly corroded. When switched on the screen does indeed go black when using either 15kHz or 31Khz video modes. There is no disk activity and just one flash of the caps lock on power on. The two IC in U480 and U477 look as though they might be damaged too.

@Fogg_80 - Thanks for the heads up. I noticed the jumper J852 which sets the memory to 256K or 1M zips. I am guessing these are 1MB. I think I have 8x1MB ZIP's somewhere I can use to bring it up to 16MB, but I will need to get this board working first.

Can someone tell me which ROMS go in which sockets? I have seen a number of MB photos online where ROM0 is in the ROM1 socket and ROM1 is in ROM0 socket.
 
Top Bottom