AMOS Pro and its dodgy compiler!

HonestFlames

New member
Joined
Aug 18, 2010
Posts
346
Country
England
Region
Shropshire
I don't know how many AMOS users there still are, but maybe you can help?

I began a project over a week ago and it initially had 1 sprite bank. I then split it into 1 sprite bank and 1 icon bank. There was only 1 icon in the icon bank and 3 sprites in the sprite bank.

When compiled, it ran fine on the 1200 but crashed on any 68000 based Amiga, be it an original A500, an A500+ or an A600. The Guru ended 003, indicating misaligned word access.

On reading similar accounts, the finger was pointed at the icon bank being the cause. I removed the bank, but I'm still seeing a crash before any screen gets initialised.

I'm going to give it another bash tonight by re-creating the source file from an ASCII import and re-drawing the 3 sprites from scratch, but I just wondered if anyone had experienced crashy AMOS executables on their A500/600 and knew of a simple workaround?

Thanks!
 

HonestFlames

New member
Joined
Aug 18, 2010
Posts
346
Country
England
Region
Shropshire
Took me a while to get around to it, but I've sorted it.

Exported to source to ASCII. Created new project. Imported ASCII. Redrew the 3 sprite images. Now compiles fine and runs on an emulated A500.
 

AmiDARK

New member
Joined
Dec 22, 2010
Posts
12
Country
France
Region
Bouches du Rhône, FRANCE
Hi :)

1. Did you pack your bank ?

2.Did you try to not include your banks in the source but to load them at the beginning of your project source code ?

Kindest Regards,
AmiDARK
 

HonestFlames

New member
Joined
Aug 18, 2010
Posts
346
Country
England
Region
Shropshire
Wow... erm. Trying to remember.

I didn't pack any banks.

I didn't load them at run-time, they were just included as part of the program.

It's been really too long for me to remember if I found the cause. I was just happy that the problem went away! I still have the source if you ever want to look at it.
 

Bastich

Active member
Joined
Apr 13, 2011
Posts
1,930
Country
United Kingdom
Region
Staffordshire
Long time since I used AMOS or its compiler. Its dodgyness :eek: was one of the main reasons I moved over to Blitz2 (y) at the time. At least it was better than the Amiga Basic compiler mind :nuts:
 
Top Bottom