Closed Atari Mega STE [Not Working]

Status
Not open for further replies.

Sleepy_Man

New member
Rating - 100%
154   0   0
Joined
Dec 3, 2010
Posts
549
Country
Netherlands
Region
Gelderland
Hi,

I have Atari Mega STE, which is not working. It powers up, spins but no picture.
I'm more a Amiga Guy, and I don't have the time to fix it.
The Warranty Seal is still intact, the Atari should have 2 MB Memory and a 40 MB Harddisk
No Mouse or Keyboard

See the attached pictures
Note this is a heavy item. It weighs more than 5 kg unpacked

Price € 60,00 excl. shipping and paypal fees [IBAN is also possible]

Thanks for looking

Shipping:
NL: € 6,75

Price € 60,00 excl. shipping and paypal fees [IBAN is also possible]
High Resolution Pictures Availble on request.

Thanks for looking

Shipping:
NL: € 6,95

EU Zone 1: € 25.00
EU Zone 2: € 31.00
EU Zone 3: € 32.30
World € 58,30
 

Attachments

  • P1050311.JPG
    P1050311.JPG
    39 KB · Views: 0
  • P1050310.JPG
    P1050310.JPG
    32.7 KB · Views: 1
  • P1050309.JPG
    P1050309.JPG
    31.6 KB · Views: 1
  • P1050308.JPG
    P1050308.JPG
    30.8 KB · Views: 1
  • P1050307.JPG
    P1050307.JPG
    33.6 KB · Views: 0
  • P1050306.JPG
    P1050306.JPG
    26.5 KB · Views: 0
  • P1050305.JPG
    P1050305.JPG
    46 KB · Views: 2
  • P1050304.JPG
    P1050304.JPG
    32.2 KB · Views: 1
  • P1050303.JPG
    P1050303.JPG
    31.9 KB · Views: 0
  • P1050302.JPG
    P1050302.JPG
    47.3 KB · Views: 0
Last edited:
Status
Not open for further replies.
Top Bottom