Blitz Basic 2 game will not run from floppy

Bastich

Active member
Joined
Apr 13, 2011
Posts
1,930
Country
United Kingdom
Region
Staffordshire
Hi all,

Ive been trying to get one of my old Blitz Basic 2 games to run straight from a floppy but am having problems.

If I load it from Workbench (OS3.9) it works fine.
If I boot my HD (A4000) with no startup and then cd to the disk and run it then it also works.

If I let floppy try and load via its own startup-sequence with or without setpatch it crashes or locks up with a jerky mouse?
If I boot the floppy with no startup-sequence (similar to the HD version that works) it still crashes?

Does anyone have any ideas what I am missing?
 

demolition

New member
AmiBayer
Joined
Oct 16, 2012
Posts
2,329
Country
Denmark
Region
Copenhagen
I don't know BB but I would guess you are missing some dependencies, like libraries or devices which can be found on your HDD but not on the floppy?
 

Bastich

Active member
Joined
Apr 13, 2011
Posts
1,930
Country
United Kingdom
Region
Staffordshire
Good old SnoopDOS (y)

It turns out it needed:
- mathtrans.library (easy spot)
- diskfont.library (only appeared when run from disk, WB did not list it)

All working now :)
 

Bastich

Active member
Joined
Apr 13, 2011
Posts
1,930
Country
United Kingdom
Region
Staffordshire
I used to use AMOS Pro but moved to BB2 as it gave you much better hardware access. Plus as you say there is also AGA and Intuition support. Ive still got all my original BB2 and use group disks and manuals.I did used to love AMOS to start with thou, ive still got the Pro disks and manual somewhere plus a few half finished games and apps.
 
Top Bottom