Commodore Mouse Trouble

Marc

New member
Joined
Jun 13, 2010
Posts
690
Country
UK
Region
Essex
Hi all

I have a commodore mouse (same as pictured below on the right) The lift click has suddenly become very wimpy. Requires a very hard press to click. Is this a common fault? Is it something I can fix? Anyone have any advice? I love this mouse and don't want to replace it :(

Thanks!

imag0158k.jpg
 

AmiNeo

CodeMonkey
Joined
Jul 28, 2010
Posts
7,436
Country
UK
Region
Kendal, Cumbria
The contacts under the buttons plastics get worn over time. They can be rather easily desoldered and replaced. I did this with a tank mouse recently and shes as good as new now.

Amigakit sell the replacement buttons you should need, these are the ones I used...

http://amigakit.leamancomputing.com/catalog/product_info.php?products_id=786

Theyre a simple through hole device and the job should be easy enough for the inexperienced solderer.
 

davideo

I look like Gizmo
Staff member
Administrator
Staff Moderator
Treasurer
Blogger
Joined
Jan 22, 2008
Posts
15,085
Country
UK
Region
Boston, Lincs
@AmiNeo

I think those are for the Tank mouse only. I don't think they fit the above mouse!!

Dave G :cool:
 

skippy

New member
Joined
Jun 3, 2008
Posts
106
Country
BRISTOL, UK
Region
Avon
I love this mouse and don't want to replace it :(
I'd be more than happy to fix a new button on for you.

Recently replace one of my own that I snaffled from an old doorbell so I could continue playing Lemmings. :LOL:

Skippy.
 

Attachments

  • mouse.jpg
    mouse.jpg
    44.1 KB · Views: 0
Top Bottom