Cybervision 64 problems - CPU caches?

lewism

Member
AmiBayer
Joined
Sep 21, 2010
Posts
118
Country
Scotland
Region
Highlands
Hi all,

I've been trying to get a 4MB Cybervision 64 working with my A4000D. My machine has an A3640 @ 25MHz, 16 meg fast ram and an Indivision AGA fitted. The Buster chip is v11.

It's a relatively clean install of OS 3.1, I do have a Deneb USB card as well with Poseidon etc installed but the card isn't currently in the machine (I took it out to see if it'd make any difference getting the Cybervision to work, but it didn't).

I've tried both Picasso96 and CybergraphX 3 from Aminet, initially with little success. With Picasso96 I'd get a blank screen if I selected "Use" after selecting a screen mode, and if I tried the "Test" button in the Picasso96 prefs the machine would just freeze.

With CybergraphX 3, the same thing would happen, blank screen.

However, I've now discovered that if I hold down both mouse buttons on boot and disable CPU caches, the card works beautifully. I've tried then re-enabling caches after boot using the cpu command, but as soon as I hit enter the computer locks up completely.

I've checked that JP1 on the Cybervision is open for Buster 11, and it is.

Has anyone experienced this before? Any other suggestions on what I can try? If I could get another CPU card, would that be likely to make a difference?

Thanks!

Edit: Just checked and the card is a Rev 3.0 A3640 with a PAL U209 version -01. I've read here (http://cap.vapor.com/AmigaResource/AmigaTechnicalResource/A4000_HardwareGuide/a3640ref.html) that this card has been known to hang or sporadically crash with some Zorro cards, the Cybervision 64 is mentioned too, but I'm not certain whether this is what I'm seeing as the machine hangs _every_ time I enable CPU caches. Is it worth trying the cut and jumper hack?
 
Last edited:
Top Bottom