help required - amiga hdd not booting

Status
Not open for further replies.

pantson

New member
Joined
Aug 1, 2008
Posts
3
Country
Bradford, UK
Hi

I have an A1200 with a 64MB Conner harddrive in it. The last time I turned it on (back in the nineties) everything worked fine. I went back to the machine last month and the HDD is makies a few clicking sounds and doesn't boot. The amiga does boot into the insert disk prompt, so i am assuming the machine still works.
I have many years of coding and graphics on my hdd and was hoping the hdd hasn't failed. Does anyone know how i can get the data off.

I have tried plugging the HD into a usb HD case, and windows does recognise it. I've tried booting from it using WinUAE (with the disableharddrivesafetycheck flag) but Winuae does not recognise it.

Does anyone know of any other ways? (fingers crossed)

I don't have any details of the harddrive on me at the mo, but will upload a piccy soon.

regards
Rich

PS yeah yeah, i should have backed it up, but on those days I didn't have 64+ blank floppy disks ;-)
 

meega

Elite ranking
Joined
Nov 24, 2007
Posts
933
Country
UK
Region
2
Re: help required - amiga hdd not booting

When you say Windows recognises it - do you mean that it actually spins up, or just that it says "Yep, that's a hard drive..."?
 

pantson

New member
Joined
Aug 1, 2008
Posts
3
Country
Bradford, UK
Re: help required - amiga hdd not booting

The hd spins up and Windows device manager says "Conner Peripheral USB".
There is still alot of clicking from the drive when loaded in Windows.
 

Zetr0

Ya' Like it Retr0?
Joined
Nov 22, 2007
Posts
9,900
Country
UK
Region
Norfolk
Re: help required - amiga hdd not booting

you could try WinUAE, and see if that can read the data from the drive.

However, it doesn't bode well i am sorry to say, my fingers are crossed for you.
 

Kin Hell

Active member
Banned
Joined
Nov 25, 2007
Posts
6,970
Country
U.K.
Region
Cornwall
Re: help required - amiga hdd not booting

If the drive is clicking all the time, there is every chance the heads are stuck. Knocking or tapping the hard drive may free the heads, it depends how much of a shock you are willing to give it.

Try holding the drive in your hand with power to it. Use an upward turned hand like a claw, so you are cradling it along the 2 sides & end opposite to the data cable-end with your fingers. As you power the Miggy up, flick the drive sharply from left to right. Repeat several times if it doesn`t work first time. It`s getting the power on with the right Inertia direction. If it frees up, you should hear the hard drive stop clicking.

When tapping the drive, tap the sides & end without the data ports. If the drive has sat clicking for too long, it may have smoked the mechanism inside!

Good luck what ever the outcome.

PS the last time I had a go at this, I was tapping the sides with a ball-hammer & switched to a Lump hammer on the Top & Bottom faces in frustration!

..but it has worked on several occasions before. .....Nil desperandum! :wink:
 

pantson

New member
Joined
Aug 1, 2008
Posts
3
Country
Bradford, UK
Re: help required - amiga hdd not booting

many thanks for all the advice.
I have tapped the hdd many times and shook it fromm side to side in the palm of my hands with no luck.
I have noticed that if i do it too often, my hdd powers down for 5 seconds and then starts up again. Is this a common feature or a sign?

I will keep trying

PS I haven't reverted to hammers yet.
 

Kin Hell

Active member
Banned
Joined
Nov 25, 2007
Posts
6,970
Country
U.K.
Region
Cornwall
Re: help required - amiga hdd not booting

...Tis sounding like "Sledge Hammer" time to me! :mrgreen:
 

Merlin

Ministry of Retr0bright and Street Judge
VIP
Joined
Nov 24, 2007
Posts
15,597
Country
UK
Region
Manchester
Re: help required - amiga hdd not booting

/Last Post on

It sounds like the controller is knackered, sorry mate, your HD has passed on.....it is an ex-hard drive. :cry:

/Last Post off

Merlin
 

Harrison

Member
Joined
Dec 1, 2007
Posts
10,153
Country
UK
Region
West Sussex
Re: help required - amiga hdd not booting

Yep, if the HD is clicking all of the time, like a metal ticking sound, then it is 99% likely to be dead. I had that happen to an Amiga HD years ago and it was dead. The clicking normally indicates that the drive has suffered from a head crash where the read head on one of the platters has physically touched the disk surface, which is instant death. Often referred to as HD click of death.

But because the HD hasn't been spun up for so many years I expect the initial cause was a seized head motor and then jammed the mechanism when you tried to switch it on after so long.

If you have stuff on the HD that you really can't live without then there are data recovery specialists that can often still recover the data, but it costs quite a lot of money to send an HD off for this. And probably even more for an exotic formatted HD like an Amiga one.
 
Status
Not open for further replies.
Top Bottom