Help setting up ClassicWB on a >4GB drive

UberFreak

Active member
AmiBayer
Joined
Sep 28, 2009
Posts
1,028
Country
Israel
Hi

I posted this on EAB as well, but here goes (a somewhat shorter version):

I tried to install ClassicWB full on a 4.5GB HDD & ran into a few problems I cant seem to solve.
The HDD is an 4.5GB IBM, all work was done on WinUAE.

Setting the first partition to 500MB, formatting with FFS & copying all WB files went ok & I could boot from my HDD.

Problems started when I partitioned the rest of the drive.
I followed the tutorial for 8GB HDD support & copied Smartfilesystem v1.84 to L: , then added it to HDToolBox.
I then created two additional partitions - DH1: which is 1GB, DH2: which is about 3.1GB, both with SFS.
Saved the changes & rebooted, the new partitions appeared on the desktop as NDOS.

Formatting DH1 was successful. I then formatted DH2 & rebooted, but now got the following requester:

"Device DH2: (uaehf.device, unit 0)
You MUST reinsert this volume!
There still was some data which needs to be transferred."

This requester shows up on every reboot now, if I click "Retry" WB loads & I can see the drive.

After copying some files into DH1 & DH2, I rebooted.
After the reboot, DH2 became NDOS again & I had to re-format it
banghead.gif

DH1 is still ok, I was able to read & write files on it.

Next I tried connecting the HDD to my A1200.
This time I got a different requester on boot - "not a DOS disk in device DH2:".
After WB loaded I tried to format DH2 again, on the A1200 this time, and was rewarded with a GURU
frown.gif

I have no idea whats happening here!

Any ideas?
guru.gif

Thanx in advance!
 
Top Bottom