Info on replacing C64 PLA (906114-01)

mjnurney

we live as we dream. Alone.
Joined
Aug 28, 2010
Posts
9,473
Country
england
Region
Milton Keynes
I'm using the super PLA and i have seen no problems so far ....it works just fine,

the PLA is a weak point on the C64
 

TheCorfiot

Out in the Wild
VIP
Joined
Mar 28, 2008
Posts
8,698
Country
Greece
Region
Corfu
Do you want to be a guinea pig and try one of my Eprom PLA's for free to see if it works for you..

Tc :)
 

genny_flick

Active member
AmiBayer
Blogger
Joined
May 13, 2011
Posts
1,051
Country
Italy
Region
Bari, Apulia
Use the Eprom version as it require only a bit of diy :)
 

TheCorfiot

Out in the Wild
VIP
Joined
Mar 28, 2008
Posts
8,698
Country
Greece
Region
Corfu
Use the Eprom version as it require only a bit of diy :)

Exactly ;)

I didn't set out to supply in bulk but I had so many C64's come through with dead PLA I didn't even have a spare to test with so I made a couple of these Eprom PLA's to use for fault finding.

I have had various success, some boards have no issues with it, others have minor issues, seems to upset access to the colour SRAM, most notably on those that have had RAM(s) replaced and they are no longer a matched set.

So if I can help anyone out and they want to try it, that's cool. It's just I can't be 100% sure it will function perfectly with all boards.

TC :)
 

Naparovitse

Member
Joined
Aug 8, 2011
Posts
108
Country
Portugal
Region
Vila Nova de Gaia
Use the Eprom version as it require only a bit of diy :)

Exactly ;)

I didn't set out to supply in bulk but I had so many C64's come through with dead PLA I didn't even have a spare to test with so I made a couple of these Eprom PLA's to use for fault finding.

I have had various success, some boards have no issues with it, others have minor issues, seems to upset access to the colour SRAM, most notably on those that have had RAM(s) replaced and they are no longer a matched set.

So if I can help anyone out and they want to try it, that's cool. It's just I can't be 100% sure it will function perfectly with all boards.

TC :)

Hi,
I have one C64 breadbin with a defect PLA, the symptom is exactly this http://derbian.webs.com/c64diag/fault.htm?id=u17_5 and my board is an
Assy no. 250407 (socket U17)
Do you already tried with this board?
Thanks
 
Top Bottom