Installing ECS Scan Doubler in A1000

AmiG

New member
AmiBayer
Joined
Apr 23, 2010
Posts
59
Country
United States
Region
Texas
I started the task of installing the ECS Scan Doubler into my A1000 this afternoon. I'm using the adapter I also purchased and I'm only slightly worried and want to make sure that I install this correctly. The A1000 adapter comes with two sockets, one labeled Paula and the other labeled ECS. There is no manual to be found for A1000 installation on Individual Computers web site. I have a message in to Amigakit where I purchased both upgrades, but thought I ask here first because it really seems simple enough. I seems to me that the Paula chip comes out and goes into the socket labeled Paula on the adapter(duh, right?) and the adpter goes into the vacant Paula socket as there is no room in for it next to Denise(Power Supply in the way). Then it would seem to me that Denise comes out to go into the ECS socket leaving the Denise socket open. I just want to verify so that I make sure I have done this exactly right. My A1000 seems to have never been opened before in it's life. This is evidenced by the fact the tabs on the heat shield were all twisted from the factory and all screws were very snug. It must be an early version as the bottom label only says Amiga with no mention of 1000. The motherboard rev. is 6. Amigakit has been wonderful answering questions in the past but as it is Saturday and already almost 9PM over there, I thought maybe someone who frequents Amibay might know so I can get my A1000 back together more quickly.:unsure:
 
Last edited:

AmiG

New member
AmiBayer
Joined
Apr 23, 2010
Posts
59
Country
United States
Region
Texas
Found the answer after searching forums all over. The socket on the ECS stays empty. Unfortunately, on my Amiga, the daughterboard connection is in the way. Need some other kind of Piggyback adapter I think, but where to find such an item? The version of the scan doubler I have looks slightly different and may be newer and the A1000 adapter may not actually work with it. I may have to use this thing in the 500 instead. :( It looks like what is actually needed is something like this:

http://www.a1k.org/forum/attachment.php?attachmentid=21649&d=1261520265

then I can install in Denise socket like normal.
 
Last edited:

AmiG

New member
AmiBayer
Joined
Apr 23, 2010
Posts
59
Country
United States
Region
Texas
After all that, I ended up putting the ECS scan doubler in my A500. I am now going to look for an external scan doubler for the A1000.
 

AmiG

New member
AmiBayer
Joined
Apr 23, 2010
Posts
59
Country
United States
Region
Texas
I really cannot figure out why I was unable to get this to fit even with instructions and the A1000 adapter. Possibly my A1000, being a very early one has different connection points on the daughterboard. I could not insert the adapter with Paula and ECS inserted into the socket on the MB because the pins to connect the daughterboard were in the way. Maybe I am just missing something, but it worked out anyway because I was able to use the ECS in my A500 and it works great there. Amigakit has been wonderful in quickly answering my questions and I will definitely do business with them again.
 
Top Bottom