logic3 Amiga mouse help

terminator

New member
Joined
Sep 25, 2010
Posts
21
Country
England
Region
Sheffield
I got this with some other bits the 9 pin plug was wired wrong well infact the plug is from sumat else that has missing pins so no way it would work so i have a joystick and mouse splitter im wanting to wire it direct into splitter but thats not the problem.The problem is i cant find a internal diagram of the mouse and seeing as the two plugs are not marked up apart from 5v/u1 not too sure were to try them any help please.
Logic3 rg 184650
 

rkauer

Amiga fanboy
Joined
Dec 17, 2007
Posts
10,337
Country
Brazil
Region
São Leopoldo, RS
First: can you insert some double enter (paragraph pauses among sentences) on your text? It is hard to read.

Now: do you have a multimeter with continuity test? If so it's easy to spot which wire comes to which pin socket.

Missing pins will not be hard to spot with a bit of calm and knowledge.
 

terminator

New member
Joined
Sep 25, 2010
Posts
21
Country
England
Region
Sheffield
First: can you insert some double enter (paragraph pauses among sentences) on your text? It is hard to read.

Now: do you have a multimeter with continuity test? If so it's easy to spot which wire comes to which pin socket.

Missing pins will not be hard to spot with a bit of calm and knowledge.
Lol yes have a meter no problem testing.
Not had a good go at it yet but was not getting anywere first time round.
So any advise welcome before i have a good go at it.
Just to update now have grey = earth / white = right mouse button / green = left mouse button blue = 5v that just leave,s 4 off out now will resume later lol
Oh well looks like maybe mouse was damged when they wired it incorrectly or even before that.Thanks anyway for Looking.
 
Last edited:
Top Bottom