memory type mbx 1200 question

jvdbossc

HypnusBE
Joined
Nov 11, 2009
Posts
3,326
Country
Belgium
Region
Antwerp (province)
Long time ago I bought a broken mbx 1200. Yesterday I recapped and cleaned the board. It used to freeze the amiga completely. Now the amiga comes on in test mode without memory.

It says in test mode, working in early boot without memory.

It says defective without memory in early boot.

When I put in 60 ns edo-ram I get yellow- flash-flash, no early boot.

There was one cap that smelt like rotten fish when heathed.

Does this card accept edo ram, or should I look for other memory. The manual states simms, 80 ns.

thanks,
 

roy_bates

resistance is futile!
AmiBayer
Blogger
Joined
Dec 18, 2011
Posts
8,387
Country
england
Region
birmingham
i dont think it will make any difference what speed simm you put in it,faster ones can run at slower speeds
 

Ed.D

Active member
Blogger
Joined
Aug 21, 2010
Posts
1,543
Country
United Kingdom
Region
Bristol
Hi JVD,

I have an MBX 1200z. The chip info on the SIMM which has 8 chips is:

Goldstar
GM71C4400BJ70
9510 KOREA

On the back of the SIMM is written "LITE ON 20V0"


Ed.
 

jvdbossc

HypnusBE
Joined
Nov 11, 2009
Posts
3,326
Country
Belgium
Region
Antwerp (province)
Hi JVD,

I have an MBX 1200z. The chip info on the SIMM which has 8 chips is:

Goldstar
GM71C4400BJ70
9510 KOREA

On the back of the SIMM is written "LITE ON 20V0"


Ed.

Thanks, that is edo-ram, so I need to look further into it...
 

roy_bates

resistance is futile!
AmiBayer
Blogger
Joined
Dec 18, 2011
Posts
8,387
Country
england
Region
birmingham
if it has any socketed ic's on the board try re-seating them especially pals and gals.
 
Top Bottom