So.... What did I actually do right???

RuneRider

A1000 Keeper of the Faith
Joined
Aug 28, 2015
Posts
407
Country
Canada
Region
Alberta
Today I removed the non-functioning floppy drive from my A3000D to see -for the 3rd time- if by some chance I could do anything to make it work. The drive made some nasty noises and every disk was non-dos as far as it could tell. I'd done a minor cleaning with the drive in one piece before but nothing more.

This time took the drive completely apart and cleaned it again as best I could. After removing enough black hairy stuff to construct a small animal from and re-seating everything I cleaned the heads with a cotton tipped stick and isopropyl alcohol.

I ran a disk-copy utility with the drive uncased to see what was happening and what may be causing the noises. It turned out that the motor was not returning the heads to the start position and made grinding noises as it tried to do so.

I removed the motor assembly, cleaned the threaded shaft off completely, applied fresh lubricant to it and put it back. This did the job and the heads moved smoothly through their complete range again.

Now I tried to format a disk again. Not working. I tried to boot with it.... nothing, Non-Dos.

I decided to run a few copy cycles, but still nothing. The error tracker filled up on both reads and writes.

I re-assembled the drive, closed up the case and rebooted from external drive. I was going to post here asking about head alignment but decided to do one final format test. This one worked and the disk showed up on my workbench and was accessible.

I then tried booting from the internal drive and it worked!

So, my question is this: What on Earth did I do that actually worked?!? The amount of head manipulation I did and cleaning with what I'd only hoped would work is surely the reason the heads messed up. Does the drive auto-align?

Anyway, I now have a fully functional internal drive and am very happy about this. :bounceBoingBall:
 
Top Bottom