Woe, Woe and Thrice Woe, my amiga woe's

Alcatan

I never drink....Wine
AmiBayer
Joined
Apr 22, 2010
Posts
318
Country
United Kingdom
Region
Ceredigion
Well this is my little birthday rant (36 today!:D), I don't seem to be having much luck with my Miggie's at the moment.

Once Woe, After unpacking all my amiga gear and setting up my book case with all my games at the beggining of August I discovered that I have lost, LOST, my Big Box copy of Agony, I had kept it in mint condition and it must have been missed during the house move last year, so now it's probably at the bottom of a landfill AAARRGGHHH!

Twice Woe, I decided to remove the battery from My A500 1.5mb ram upgrade board, last weekend just incase the battery decided to leak. last time I checked it, it was all clean and dandy, though that was about 4 weeks ago, booted it up last weekend, 500kb Ram, checked board battery had leaked frikkin everywhere AAAAAARRGGHHHH!

Thrice Woe, and to boot I was swapping out my Hard drive on my A1200 on the weekend, and when I pulled the IDE cable from the socket, one of the PIN's came away with the cable, luckily though I had a spare (one of many) Rev 1d4 Mobo's sitting in the wings.

As they say, bad luck always comes in three's.
 

ajk

Active member
AmiBayer
Joined
May 16, 2010
Posts
1,053
Country
Finland
Region
Helsinki
As for the second woe, if it only has started leaking in the last month, most likely you don't have serious corrosion yet, just a mess. Clean it away as soon as you can, though :)
 

LamboJay

Member
AmiBayer
Joined
Jul 26, 2010
Posts
335
Country
USA
Region
Charlotte, NC
I feel your pain on the first woe. I lost entire A2000 and A4000 systems during a house move a few years ago. :( Hence the MIA (missing in action) in my sig.
 

tokyoracer

(Not actually from Tokyo).
Blogger
Joined
Jun 5, 2008
Posts
4,907
Country
United Kingdom
Region
Norfolk
Thrice Woe, and to boot I was swapping out my Hard drive on my A1200 on the weekend, and when I pulled the IDE cable from the socket, one of the PIN's came away with the cable, luckily though I had a spare (one of many) Rev 1d4 Mobo's sitting in the wings.
That happend to me a few weeks ago, 'cept I lost 3 pins! I hope a good friend of mine can fix it when I got the cash to send it off (with other stuff too).

I feel your pain on that one. :(
 

fitzsteve

Retired Slacker
AmiBayer
Blogger
Joined
Aug 19, 2009
Posts
19,981
Country
UK
Region
Sevenoaks
Mate that sucks, lets hope thats the bad luck out the way and the Amiga gods provide you with something awesome :cool:

All the best!

Steve.
 
Top Bottom